Adventures with Firewire

 

I have an ancient Hasselblad. H4D40, dating from about 2010. It has been mine (slightly damaged, second hand) from 2015. It has a Firewire connection for tethering. In it’s day Firewire aka IEEE1394 was state of the art, a technology from Apple, universally used in the music and graphics industry for fast connections to peripheral equipment. 
Firewire has, however, been superceded by Thunderbolt and USB C.  Apple stopped putting Firewire ports on their computers years ago. Fortunately they did sell a Firewire to Thunderbolt (2) adapter, so for some years I used a 13 inch Macbook Pro with this adapter. But that Macbook had only 8gb of RAM, which Apple made non upgradeable, and when I recently upgraded I decided to go with a Lenovo X1 Extreme. Of course it does not have Thunderbolt 2 ports, but does have  USB C ports, which are for the most part compatible with Apple’s Thunderbolt 3.  I had researched this before my purchase, and bought a Thuderbolt 2 to Thunderbot 3 adapter: so plugging my Firewre cable into the Firewire to Thunderbolt 2 adapter, and this into the Thunderbolt 2 to Thunderbolt 3 adapter, and this into the USB C port on my Thinkpad, I was good to go. 
Except for some mysterious intermittent problems. Most went away with driver and firmware upgrades, but one remained.  Shooting tethered would work perfectly – for a while, then the connection to the laptop would drop without warning. Checking the screen would reveal that the last few shots had not been captured to the laptop. Fortunately they went to the card on the camera, so all was not lost. Initially I assumed that this was due to cable issues from shooting handheld, but most recently it happened with the camera on  a heavy tripod, and the cable secured at both ends to prevent strain. 
So I delved into Windows System Log, a place I have avoided since I left the server support industry, and there I found the following entry:
The driver has detected a device with old or out-of-date firmware.  The device will not be used.
So effectively, after using the connected camera for half an hour or so, Windows reviewed the situation, determined that the firmware (on the camera?) was ‘out of date’ (though at the most recent version) and shut down the port. Without posting any informative message. 
At this point I was considering either not using the Hasselblad, or going back to the old Macbook Pro.  But apparently this problem with Firewire has been known since Windows 7, and there is a solution: to change the Firewire driver to the legacy version, which was included in Windows 7 but was removed from Windows 8 onward. A quick search on Google found the driver, and equally quickly it was downloaded and installed.
Worked like magic – for a while.  Soon I was receiving those ‘Capture failed’ messages again, and communication with the laptop was lost.  It turned out that automatic upgrades had replaced the legacy driver with the later one, and changing the driver back was an easy fix. The missing images were saved to the camera card, so nothing was lost. It looked like the problem was solved.
But it was not so simple. Later I received the same messages again, but the driver had not changed, it was still the legacy driver. So some other issue had cropped up,  So far i don’t know what it is. There is nothing in the system log to indicate an error.  And the usb port had apparently shut down, as I could not get my Sony to connect without restarting the computer. I am now seriously considering sellng the Hasselblad, and certainly won’t be using it again for tethered people shoots. Perhaps for product. We shall see.